立即注册找回密码
 

慧之家

[其他代码] php环境无法上传文件的解决方法

[复制链接]

369

主题

1332

帖子

1181

热度值

 任何值得你去的地点都没有捷径只有努力! 

最佳原创年度贡献荣誉管理优秀版主突出贡献灌水之王宣传达人推广达人热心会员活跃会员最佳新人论坛元老

发表于 2019-8-8 21:11:49 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册  

x
一、 检查网站目录的权限。

上传目录是否有写入权限。

二、 php.ini配置文件
php.ini中影响上传的有以下几处:

file_uploads 是否开启 on 必须开启

是否允许HTTP文件上传

post_max_size = 8M

PHP接受的POST数据最大长度。此设定也影响到文件上传。
要上传大文件,该值必须大于"upload_max_filesize"
如果配置脚本中激活了内存限制,"memory_limit"也会影响文件上传。
一般说来,"memory_limit"应该比"post_max_size"要大。

upload_max_filesize = 2M

允许上传的文件的最大尺寸

upload_tmp_dir = C:\windows\temp
文件上传时存放文件的临时目录。必须是PHP进程用户可写的目录。如果未指定则PHP使用系统默认值

default_socket_timeout = 60
socket超时,单位是秒

max_execution_time = 30
每个脚本最大允许执行时间, 按秒计。默认为30秒。
这个参数有助于阻止劣质脚本无休止的占用服务器资源。
注: "max_execution_time"仅影响脚本本身的运行时间。
任何其它花费在脚本运行之外的时间,如用system()/sleep()函数的使用、数据库查询、文件上传等都不包括在内。
在安全模式下,你不能用ini_set()在运行时改变这个设置

max_input_time = 60
每个脚本接收输入数据的最大允许时间(POST, GET, upload), 按秒计

memory_limit = 128M
设定一个脚本所能够申请到的最大内存字节数。
这有助于防止劣质脚本消耗完服务器上的所有内存。
要使用此指令必须在编译的时候激活。
因此 configure 一行中应该包括:--enable-memory-limit
如果不需要任何内存上的限制,必须将其设为 -1
自php4.3.2 起,当设置了memory_limit后,memory_get_usage()函数将变为可用

三、upload_tmp_dir目录权限
如果php配置没问题,那问题有可能出在upload_tmp_dir设定的目录权限问题。加入IIS_WPG除完全控制外的权限,users的读写权限,NETWORK SERVER除完全控制外的权限。

四、如果起用了ZEND,看Temp文件夹中是否有ZendOptimizer.MemoryBase@SYSTEM和ZendOptimizer.MemoryBase@NETWORKSERVICE,如果没有,就建立它。

五、如果以上都不行,那问题很有可能出在这里了,检查windows目录是否禁用guests来宾组,要给windows目录users组 读取和执行权限。
该会员没有填写今日想说内容.
使用高级回帖 (可批量传图、插入视频等)

发表回复

您需要登录后才可以回帖 登录 | 立即注册  

本版积分规则   Ctrl + Enter 快速发布  

发帖时请遵守我国法律,网站会将有关你发帖内容、时间以及发帖IP地址等记录保留,只要接到合法请求,即会将信息提供给有关政府机构。
站点服务大厅 官方群